adfea95a61bb45b67922602725aac73296fd1b9e
[rsync/rsync.git] / popt-1.2 / popt.spec
1 Summary: C library for parsing command line parameters
2 Name: popt
3 Version: 1.2
4 Release: 1
5 Copyright: LGPL
6 Group: Libraries
7 Source: ftp://ftp.redhat.com/pub/redhat/code/popt/popt-%{version}.tar.gz
8 BuildRoot: /var/tmp/popt.root
9
10 %description
11 Popt is a C library for pasing command line parameters. It was heavily
12 influenced by the getopt() and getopt_long() functions, but it allows
13 more powerfull argument expansion. It can parse arbitrary argv[] style
14 arrays and automatically set variables based on command line arguments.
15 It also allows command line arguments to be aliased via configuration
16 files and includes utility functions for parsing arbitrary strings into
17 argv[] arrays using shell-like rules. 
18
19 %prep
20 %setup -q
21 CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=/usr
22
23 %build
24 make
25
26 %install
27 make DESTDIR=$RPM_BUILD_ROOT install
28
29 %clean
30 rm -rf $RPM_BUILD_ROOT
31
32 %files
33 %attr(0644, root, root) /usr/lib/libpopt.a
34 %attr(0644, root, root) /usr/include/popt.h
35
36 %changelog
37 * Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
38 - see CHANGES file for 1.2
39
40 * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
41 - added ./configure step to spec file