Preparing for release of 3.0.1
[rsync/rsync.git] / packaging / lsb / rsync.spec
index a28bfb0..0472e82 100644 (file)
@@ -1,9 +1,12 @@
 Summary: A fast, versatile, remote (and local) file-copying tool
 Name: rsync
-Version: 3.0.0pre9
+Version: 3.0.1
+%define fullversion %{version}
 Release: 1
+%define srcdir src
 Group: Applications/Internet
-Source:        http://rsync.samba.org/ftp/rsync/rsync-%{version}.tar.gz
+Source0: http://rsync.samba.org/ftp/rsync/%{srcdir}/rsync-%{fullversion}.tar.gz
+Source1: http://rsync.samba.org/ftp/rsync/%{srcdir}/rsync-patches-%{fullversion}.tar.gz
 URL: http://rsync.samba.org/
 
 Prefix: %{_prefix}
@@ -22,9 +25,18 @@ destination.  Rsync is widely used for backups and mirroring and as an
 improved copy command for everyday use.
 
 %prep
-%setup -q
+# Choose one -- setup source only, or setup source + rsync-patches:
+%setup -q -n rsync-%{fullversion}
+#%setup -q -b1 -n rsync-%{fullversion}
+
+# If you you used "%setup -q -b1", choose the patches you wish to apply:
+#patch -p1 <patches/acls.diff
+#patch -p1 <patches/xattrs.diff
+#patch -p1 <patches/remote-option.diff
+#patch -p1 <patches/db.diff
 
 %build
+#./prepare-source
 %configure
 
 make
@@ -34,16 +46,26 @@ rm -rf $RPM_BUILD_ROOT
 
 %makeinstall
 
+mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
+install -m 644 packaging/lsb/rsync.xinetd $RPM_BUILD_ROOT/etc/xinetd.d/rsync
+
+#install -p -m 755 support/rsyncdb $RPM_BUILD_ROOT/usr/bin/rsyncdb
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
 %doc COPYING README tech_report.tex
-%{_prefix}/bin/rsync
+%config(noreplace) /etc/xinetd.d/rsync
+%{_prefix}/bin/rsync*
 %{_mandir}/man1/rsync.1*
 %{_mandir}/man5/rsyncd.conf.5*
 
 %changelog
-* Sun Feb 10 2008 Wayne Davison <wayned@samba.org>
-Released 3.0.0pre9.
+* Thu Apr 03 2008 Wayne Davison <wayned@samba.org>
+Released 3.0.1.
+
+* Fri Mar 21 2008 Wayne Davison <wayned@samba.org>
+Added installation of /etc/xinetd.d/rsync file and some commented-out
+lines that demonstrate how to use the rsync-patches tar file.