Some RPM spec file improvements:
[rsync/rsync.git] / packaging / lsb / rsync.spec
1 Summary: A fast, versatile, remote (and local) file-copying tool
2 Name: rsync
3 Version: 3.0.0
4 Release: 1
5 Group: Applications/Internet
6 Source0: http://rsync.samba.org/ftp/rsync/rsync-%{version}.tar.gz
7 Source1: http://rsync.samba.org/ftp/rsync/rsync-patches-%{version}.tar.gz
8 URL: http://rsync.samba.org/
9
10 Prefix: %{_prefix}
11 BuildRoot: /var/tmp/%{name}-root
12 License: GPL
13
14 %description
15 Rsync is a fast and extraordinarily versatile file copying tool.  It can
16 copy locally, to/from another host over any remote shell, or to/from a
17 remote rsync daemon.  It offers a large number of options that control
18 every aspect of its behavior and permit very flexible specification of the
19 set of files to be copied.  It is famous for its delta-transfer algorithm,
20 which reduces the amount of data sent over the network by sending only the
21 differences between the source files and the existing files in the
22 destination.  Rsync is widely used for backups and mirroring and as an
23 improved copy command for everyday use.
24
25 %prep
26 # Choose one -- setup source only, or setup source + rsync-patches:
27 %setup -q
28 #%setup -q -b1
29
30 # If you you used "%setup -q -b1", choose the patches you wish to apply:
31 #patch -p1 <patches/acls.diff
32 #patch -p1 <patches/xattrs.diff
33 #patch -p1 <patches/checksum-reading.diff
34
35 %build
36 %configure
37
38 make
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %makeinstall
44
45 mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
46 install -m 644 packaging/lsb/rsync.xinetd $RPM_BUILD_ROOT/etc/xinetd.d/rsync
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(-,root,root)
53 %doc COPYING README tech_report.tex
54 %config(noreplace) /etc/xinetd.d/rsync
55 %{_prefix}/bin/rsync
56 %{_mandir}/man1/rsync.1*
57 %{_mandir}/man5/rsyncd.conf.5*
58
59 %changelog
60 * Sat Mar 01 2008 Wayne Davison <wayned@samba.org>
61 Released 3.0.0.
62
63 * Fri Mar 21 2008 Wayne Davison <wayned@samba.org>
64 Added installation of /etc/xinetd.d/rsync file and some commented-out
65 lines that demonstrate how to use the rsync-patches tar file.