Preparing for release of 3.0.1pre1
[rsync/rsync.git] / packaging / lsb / rsync.spec
1 Summary: A fast, versatile, remote (and local) file-copying tool
2 Name: rsync
3 Version: 3.0.1
4 %define fullversion %{version}pre1
5 Release: 0.1.pre1
6 Group: Applications/Internet
7 Source0: http://rsync.samba.org/ftp/rsync/%{name}-%{fullversion}.tar.gz
8 Source1: http://rsync.samba.org/ftp/rsync/%{name}-patches-%{fullversion}.tar.gz
9 URL: http://rsync.samba.org/
10
11 Prefix: %{_prefix}
12 BuildRoot: /var/tmp/%{name}-root
13 License: GPL
14
15 %description
16 Rsync is a fast and extraordinarily versatile file copying tool.  It can
17 copy locally, to/from another host over any remote shell, or to/from a
18 remote rsync daemon.  It offers a large number of options that control
19 every aspect of its behavior and permit very flexible specification of the
20 set of files to be copied.  It is famous for its delta-transfer algorithm,
21 which reduces the amount of data sent over the network by sending only the
22 differences between the source files and the existing files in the
23 destination.  Rsync is widely used for backups and mirroring and as an
24 improved copy command for everyday use.
25
26 %prep
27 # Choose one -- setup source only, or setup source + rsync-patches:
28 %setup -q -n %{name}-%{fullversion}
29 #%setup -q -n %{name}-%{fullversion} -b1
30
31 # If you you used "%setup -q -b1", choose the patches you wish to apply:
32 #patch -p1 <patches/acls.diff
33 #patch -p1 <patches/xattrs.diff
34 #patch -p1 <patches/checksum-reading.diff
35
36 %build
37 %configure
38
39 make
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %makeinstall
45
46 mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
47 install -m 644 packaging/lsb/rsync.xinetd $RPM_BUILD_ROOT/etc/xinetd.d/rsync
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(-,root,root)
54 %doc COPYING README tech_report.tex
55 %config(noreplace) /etc/xinetd.d/rsync
56 %{_prefix}/bin/rsync
57 %{_mandir}/man1/rsync.1*
58 %{_mandir}/man5/rsyncd.conf.5*
59
60 %changelog
61 * Mon Mar 24 2008 Wayne Davison <wayned@samba.org>
62 Released 3.0.1pre1.
63
64 * Fri Mar 21 2008 Wayne Davison <wayned@samba.org>
65 Added installation of /etc/xinetd.d/rsync file and some commented-out
66 lines that demonstrate how to use the rsync-patches tar file.